Mantis Bug Tracker

View Issue Details Jump to Notes ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000081FirmwareSerial Commspublic2008-12-02 23:522011-12-04 03:39
ReporterFred 
Assigned ToFred 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.2.0Fixed in Version0.2.0 
Summary0000081: Find a way to remove extra start byte hack.
DescriptionWithout the hack, when sending a lot of data, there is no start byte sent. With the hack, when sending no data, there are 2 sent.

I suspect perhaps its still sending the last byte and thus doesn't get the first one and ignores it. Perhaps poll flags before writing out?
TagsNo tags attached.
FirmwareVersion
Issue TypeBug
Risk of Breakagemedium
Attached Files

- Relationships

-  Notes
User avatar (0000160)
Fred (administrator)
2009-02-22 18:41

This seems to be an issue for the start byte too. It's like we are losing the ends of various things at random. I'll be performing some more testing now to eliminate issues (even if I have to put hacks in) and posting here again soon.
User avatar (0000161)
Fred (administrator)
2009-02-22 20:03

Second hack works just like the first and just as well too. Now all packets have two start and two stop bytes. Some percentage of the time they get lost though...

We need to suss out why and remove these hacks by putting a proper fix in whatever it is.
User avatar (0000890)
Fred (administrator)
2011-12-03 19:35

Finally fixed this bastard! About time too :-) AWESOME!!! :-) Available in hash dbeb2e19c278b8de8f679697b746e809127ee15d woo hoo!!! :-)


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker