FreeEMS Issues - OLV
View Issue Details
0000648OLVUser Interfacepublic2012-08-11 00:172012-08-15 13:36
Fred 
Fred 
normalminorsometimes
closedfixed 
AllAllAll
0.0.3-SNAPSHOT 
0.0.30.0.3 
0000648: Indication of button press no longer works
Buttons used to go dark while being pressed. They no longer do that. Ben says they should move a pixel, but they don't do that on lin or mac either. Some sort of press-indication should be given consistently across all three platforms. Highlight/darken seems nicest?

Marked sometimes because Ben says it works on winblows.
No tags attached.

Notes
(0001879)
BenFenner   
2012-08-14 15:51   
(edited on: 2012-08-14 15:52)
Why should the press indication be the same across all platforms? I think different platforms might have different practices for that? I think they do, since the buttons used to go dark for you but on Windows they never did that (they appear to move as if pressed).

I'll get to the bottom of this, but it will require more of this back-and-forth testing. =(

(0001880)
Fred   
2012-08-14 16:00   
because it's not a platform widget, it's a custom look internal to the app. What you're saying is like saying the lines and fonts internal to the app should be different per platform, which they shouldn't, but, incidentally, are.
(0001890)
BenFenner   
2012-08-15 13:25   
This should be fixed in git hash: 5c1c4f3a75292802acc0d13a68e9e1236f2b64ed
(0001891)
Fred   
2012-08-15 13:36   
This didn't appear to be an issue on mac at all. I may have been looking at some of the buttons on which it wasn't obvious. It now works on Linux, however different ones are less obvious. In future we'll make a new issue to make behaviour OLV-specific and consistent across all platforms. For now, each has a working indication of some sort.