FreeEMS Issues - EMStudio
View Issue Details
0000583EMStudioUser Interfacepublic2012-06-11 11:432012-07-22 13:39
Dan 
Dan 
highmajoralways
closedfixed 
MicrosoftWindows7
 
0.0.10.0.1 
Bug
0000583: Changing COM port in settings menu doesnt refresh
Changed COM port name is not updated in the settings menu when saved.
Change COM port from default and hit save. Then re-open settings menu.
No tags attached.

Notes
(0001555)
Fred   
2012-06-11 11:47   
App uses saved setting in file, but displays default in the gui, thus confusing and upsetting the user. :-(
(0001560)
malcom2073   
2012-06-11 13:13   
Fixed in 591bdeb43627b5d5902f419a02dafcfb9398382a
(0001562)
malcom2073   
2012-06-11 13:36   
Assigned to Fred, since Dan doesn't have an account?
(0001563)
Fred   
2012-06-11 13:37   
Changed his status and assigned to him.
(0001567)
Fred   
2012-06-11 14:16   
Works on Linux, leaving for Dan to test on Winblows.
(0001568)
Fred   
2012-06-11 14:17   
Dan, launch app from cmd window so you can watch cli output with valuable info.
(0001573)
malcom2073   
2012-06-11 19:04   
That doesn't work in windows. To get console output, you need debugview http://technet.microsoft.com/en-us/sysinternals/bb896647.aspx [^]
(0001576)
Fred   
2012-06-11 19:23   
Is that because it's on std err? (just asking, not trying to be a prick)
(0001577)
malcom2073   
2012-06-11 19:34   
Nope, in windows, console output doesn't go to console, since applications are run in a new process separate from the console.

The console in windows isn't REALLY a console.
(0001578)
Fred   
2012-06-11 19:47   
OK, thanks. If he launches it from git-bash (cygwin) will it display?
(0001706)
Fred   
2012-07-22 13:39   
Tested as fixed.